Интеграция 1С и Trello

Публикация № 1357250

Разработка - Системная интеграция - Интеграция

Trello Интеграция

В публикации и приложенной обработке описываются методы взаимодействий между 1С и облачным сервисом Trello по API.

В примерах описан далеко не весь набор API, включены те методы, которые использованы в разработке Тикеты - система учета задач/Help Desk в 1С (интеграция с Trello)

Токен и ключ можно после авторизации в сервисе Trello получить по адресу trello.com/app-key

Обработку открывать из любой конфигурации на управляемых формах, под любой версией платформы.

Обработка тестировалась на платформе 8.3.17

Чтение

Функция ВыполнитьЗапросКСерверу(ТекстЗапроса)
    
    Соединение = Новый HTTPСоединение("api.trello.com",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    Запрос = Новый HTTPЗапрос(ТекстЗапроса + "key=" + Ключ + "&token=" + Токен);
    Результат = Соединение.Получить(Запрос);
    ЧтениеJSON = Новый ЧтениеJSON;
    ЧтениеJSON.УстановитьСтроку(Результат.ПолучитьТелоКакСтроку());
    РезультатЗапроса = ПрочитатьJSON(ЧтениеJSON);
    ЧтениеJSON.Закрыть();
    
    Возврат(РезультатЗапроса);
    
КонецФункции

Функция ДатаTrello(ДатаИсточник)
    
    Если ДатаИсточник = Дата(1, 1, 1, 0, 0, 0) Тогда
        Рез = "";
    Иначе
        Рез = XMLСтрока(ДатаИсточник) + ".000Z"; 
    КонецЕсли;
    
    Возврат(Рез);
    
КонецФункции


Доски пользователя

//Получаем ID пользователя по адресу электронной почты
    ТекстЗапроса = "1/search/members/?query=" + ЭлектроннаяПочта + "&limit=1&onlyOrgMembers=false&";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);
    
     Если ТипЗнч(РезультатЗапроса) = Тип("Массив") И (РезультатЗапроса.Количество() > 0)  Тогда
        IDПользователя = РезультатЗапроса[0].id;
    Иначе
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "В Trello не найден пользователь по e-mail """ + ЭлектроннаяПочта + """";
        Сообщение.Сообщить();
        Возврат;
    КонецЕсли;
    
    //Получаем все доски пользователя
    ТекстЗапроса = "1/members/" + IDПользователя + "/boards?filter=all&fields=all&lists=none&memberships=none&organization=true&organization_fields=name%2CdisplayName&";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Колонки доски

ТекстЗапроса = "1/boards/" + IDДоски + "/lists?";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Пользовательские поля доски

ТекстЗапроса = "1/boards/" + IDДоски + "/customFields?";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Карточки колонки

ТекстЗапроса = "1/lists/" + IDКолонки + "/cards?";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Комментарии и файлы карточки

Фильтр = "commentCard,addAttachmentToCard";
    ТекстЗапроса = "1/cards/" + IDКарточки + "/actions/?limit=1000&filter=" + Фильтр + "&since=" + ДатаTrello(НачалоДня(ПериодСобытий.ДатаНачала)) + "&before=" + ДатаTrello(КонецДня(ПериодСобытий.ДатаОкончания)) + "&";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Действия с карточкой

Фильтр = "commentCard,addAttachmentToCard,addMemberToCard,removeMemberFromCard,updateCard,moveCardToBoard";
    ТекстЗапроса = "1/cards/" + IDКарточки + "/actions/?limit=1000&filter=" + Фильтр + "&since=" + ДатаTrello(НачалоДня(ПериодСобытий.ДатаНачала)) + "&before=" + ДатаTrello(КонецДня(ПериодСобытий.ДатаОкончания)) + "&";
    РезультатЗапроса = ВыполнитьЗапросКСерверу(ТекстЗапроса);

 

Скачивание прикрепленного файла (из ранее заполненной таблицы)

  Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
    Если Диалог.Выбрать() Тогда
        КопироватьФайл(ТекущаяСтрока.ПутьКФайлу, Диалог.Каталог + "\" + ТекущаяСтрока.Комментарий);
    КонецЕсли;

 

Запись

Функция ВыполнитьЗаписьНаСервере(ТекстЗапроса)
    
    Соединение = Новый HTTPСоединение("api.trello.com",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    Запрос = Новый HTTPЗапрос(ТекстЗапроса + "key=" + Ключ + "&token=" + Токен);
    Результат = Соединение.Записать(Запрос);
    
    Возврат(Результат.КодСостояния);
    
КонецФункции

Функция Дата1С(ДатаISO)
    
    Если ДатаISO = Неопределено ИЛИ ПустаяСтрока(ДатаISO) Тогда
        Возврат(Дата(1, 1, 1, 0, 0, 0));
    КонецЕсли;
    
    Возврат(XMLЗначение(Тип("Дата"), ДатаISO));
    
КонецФункции

 

Переместить на доску

ТекстЗапроса = "1/cards/" + IDКарточки + "/?idBoard=" + Результат.Значение + "&";
        РезультатЗапроса = ВыполнитьЗаписьНаСервере(ТекстЗапроса);

 

Переместить в колонку

ТекстЗапроса = "1/cards/" + IDКарточки + "/?idList=" + Результат.Значение + "&";
        РезультатЗапроса = ВыполнитьЗаписьНаСервере(ТекстЗапроса);

 

Установить тему

ТекстЗапроса = "1/cards/" + IDКарточки + "/?name=" + Тема + "&";
    Результат = ВыполнитьЗаписьНаСервере(ТекстЗапроса);

 

Установить дату исполнения

ТекстЗапроса = "1/cards/" + IDКарточки + "/?due=" + ?(ДатаИсполнения = Дата(1, 1, 1, 0, 0, 0), "", ДатаTrello(УниверсальноеВремя(ДатаИсполнения))) + "&";
    Результат = ВыполнитьЗаписьНаСервере(ТекстЗапроса);

 

Добавить комментарий

Соединение = Новый HTTPСоединение("api.trello.com",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    Запрос = Новый HTTPЗапрос("1/cards/" + IDКарточки + "/actions/comments/?text=" + Комментарий + "&key=" + Ключ + "&token=" + Токен);
    Результат = Соединение.ОтправитьДляОбработки(Запрос);

 

Добавить файл

ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    ДиалогВыбора.МножественныйВыбор = Ложь;
    Если ДиалогВыбора.Выбрать() Тогда
        ПутьКФайлу = ДиалогВыбора.ПолноеИмяФайла;
        Поз = СтрНайти(ПутьКФайлу, "\", НаправлениеПоиска.СКонца);
        Если Поз > 0 Тогда
            ИмяФайла = Прав(ПутьКФайлу, СтрДлина(ПутьКФайлу) - Поз);
            ДвоичныеДанныеФайла = Новый ДвоичныеДанные(ПутьКФайлу);
            
            Соединение = Новый HTTPСоединение("api.trello.com",,,,,, Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос("1/cards/" + IDКарточки + "/attachments/?key=" + Ключ);
            boundary = СтрЗаменить(Новый УникальныйИдентификатор,"-","");
            МассивДД = Новый Массив;
            Запрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary=" + boundary);
            ПереводСтроки = Символы.ВК + Символы.ПС;
            Текст = "--" + boundary + ПереводСтроки;
            Текст = Текст + "Content-Disposition: form-data; name=""token""" + ПереводСтроки + ПереводСтроки;
            Текст = Текст + Токен + ПереводСтроки;
            Текст = Текст + "--" + boundary + ПереводСтроки;
            Текст = Текст + "Content-Disposition: form-data; name=""file""; filename=""" + ИмяФайла + """" + ПереводСтроки + ПереводСтроки;
            МассивДД.Добавить(ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(ПолучитьБуферДвоичныхДанныхИзСтроки(Текст, КодировкаТекста.UTF8, Ложь)));
            МассивДД.Добавить(ДвоичныеДанныеФайла);    
            Текст = ПереводСтроки;
            Текст = Текст + "--" + boundary + "--" + ПереводСтроки + ПереводСтроки;
            МассивДД.Добавить(ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(ПолучитьБуферДвоичныхДанныхИзСтроки(Текст, КодировкаТекста.UTF8, Ложь)));
            ТелоДД = СоединитьДвоичныеДанные(МассивДД);
            Запрос.УстановитьТелоИзДвоичныхДанных(ТелоДД);
            Результат = Соединение.ОтправитьДляОбработки(Запрос);
            Если Результат.КодСостояния = 200 Тогда
                ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Файл успешно добавлен");
            Иначе
                ПоказатьПредупреждение(, "Не удалось добавить файл !");
            Конецесли;
        КонецЕсли;
    КонецЕсли;

 

Установка пользовательского поля

Соединение = Новый HTTPСоединение("api.trello.com",,,,,,Новый ЗащищенноеСоединениеOpenSSL());
    Запрос = Новый HTTPЗапрос("1/cards/" + IDКарточки + "/customField/" + СтрокаТаблицы.ID + "/item?key=" + Ключ + "&token=" + Токен);
    Запрос.Заголовки.Вставить("Content-Type", "application/json");
    
    ЗаписьJSON = Новый ЗаписьJSON;
    ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " ", Истина);
    ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);
    
    Если ЗначениеПоля = "" ИЛИ ЗначениеПоля = 0 ИЛИ ЗначениеПоля = Неопределено Тогда
        Если Строка(СтрокаТаблицы.ТипЗначения) = "Строка" И СтрокаТаблицы.СписокЗначений.Количество() > 0 Тогда
            СтруктураДанныхJSON = Новый Структура("idValue", "");
        Иначе
            СтруктураДанныхJSON = Новый Структура("value", "");
        КонецЕсли;
    ИначеЕсли СтрокаТаблицы.ТипЗначения = Новый ОписаниеТипов("Булево") И НЕ ЗначениеПоля Тогда
        СтруктураДанныхJSON = Новый Структура("value", "");
    Иначе
        Если Строка(СтрокаТаблицы.ТипЗначения) = "Строка" И СтрокаТаблицы.СписокЗначений.Количество() > 0 Тогда
            СтруктураДанныхJSON = Новый Структура("idValue", ЗначениеПоля);
        Иначе
            Если Строка(СтрокаТаблицы.ТипЗначения) = "Строка" Тогда
                СтруктураДанныхПоля = Новый Структура("text", Строка(ЗначениеПоля));
            ИначеЕсли Строка(СтрокаТаблицы.ТипЗначения) = "Число" Тогда
                СтруктураДанныхПоля = Новый Структура("number", СтрЗаменить(СтрЗаменить(Строка(ЗначениеПоля), Символы.НПП, ""), ",", "."));
            ИначеЕсли СтрокаТаблицы.ТипЗначения = Новый ОписаниеТипов("Булево") Тогда
                СтруктураДанныхПоля = Новый Структура("checked", "true");
            ИначеЕсли Строка(СтрокаТаблицы.ТипЗначения) = "Дата" Тогда
                СтруктураДанныхПоля = Новый Структура("date", ДатаTrello(ЗначениеПоля));
            КонецЕсли;
            СтруктураДанныхJSON = Новый Структура("value", СтруктураДанныхПоля);
        КонецЕсли;
    КонецЕсли;
    
    ЗаписатьJSON(ЗаписьJSON, СтруктураДанныхJSON);
    СтрокаJS = ЗаписьJSON.Закрыть();
    Запрос.УстановитьТелоИзСтроки(СтрокаJS, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
    
    Результат = Соединение.Записать(Запрос);

 

Скачать файлы

Наименование Файл Версия Размер
Интеграция 1С и Trello:

.epf 16,76Kb
0
.epf 16,76Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Тикеты - система учета задач/Help Desk в 1С (интеграция с Trello) Промо

Интеграция Управление бизнес-процессами (BPM) v8 v8::УФ 1cv8.cf Платные (руб)

Система предназначена для учета задач в 1С как между пользователем — разработчиком, так и для внутренних нужд организаций в качестве обслуживания бизнес-процессов. Основное преимущество разработки - это подключение клиентской части в виде внешней обработки или расширения к базе любой конфигурации 1С и обмен в задачах сущностями данных: печатные формы, отчеты, ссылки. Серверная часть представляет собой конфигурацию "Тикеты" с опубликованным web-сервисом.

8500 руб.

18.01.2019    16438    1    55    

Получение скриншота с камеры Hikvision при digest-аутентификации

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Имея подключенную ip-камеру, требуется по нажатию кнопки в документе 1С получать изображение. Может быть полезна при организации рабочих мест на проходных, весовых и т.п.

1 стартмани

30.12.2020    906    0    garagauto    0    

Пример работы с API СБИС ЭДО

Интеграция Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Пример авторизации, получения информации по документам, закрытия сессии. Обработка подойдет для тех, у кого возникли проблемы с подключением к сервису из 1С.

2 стартмани

08.12.2020    779    3    winapi    0    

Загрузка данных в 1С:Бухгалтерию ред. 3.0 из файла (DBF) СмартАптека.

Обработка документов Файловые протоколы обмена, FTP Внешние источники данных Интеграция v8 БП3.0 Фармацевтика, аптеки Россия Абонемент ($m)

Загрузка данных в 1С:Бухгалтерию ред. 3.0 из файла (DBF) СмартАптека. Возможность переноса прихода - Поступление товаров, реализации - Отчет о розничных продажах, Реализация товаров, перемещение между складами - Перемещение товаров. Товар свернут, суммовой учет. Автоматический формирует КО, себестоимость устанавливает из СмартАптеки для КУДиР.

2 стартмани

04.12.2020    566    0    art-nv    0    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    47050    5    milkers    2    

Интеграция UDS и УНФ

Розничная торговля Интеграция v8::УФ УНФ Россия УУ Абонемент ($m)

Расширение позволяет при продаже через РМК накапливать и списывать баллы UDS, соблюдены все требования 1С к разработке облачных расширений - можно подключать к облаку.

2 стартмани

25.10.2020    1216    5    viktor_and_ko    11    

Формирование файла загрузки реализаций для сайта sti.gov.kg

Интеграция Налоговые v8 БП1.6 Кыргызстан НУ НДС Абонемент ($m)

Обработка предназначена для старых версий БП для Кыргызстана 1.6 и 1.7

1 стартмани

18.09.2020    1267    0    Fox-trot    0    

Загрузка выручек касс по API с 1-ОФД (1-OFD.RU)

Обработка документов Кассовые операции ККМ Интеграция v8 Розница Абонемент ($m)

Обработка позволяет формировать отчеты о розничных продажах средствами API с 1-ОФД (1-OFD.RU)

2 стартмани

18.09.2020    1484    5    ketr    2    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами Промо

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    40885    84    lunjio    15    

Загрузка из Frontol. Расширение для БП (КОРП)

Интеграция ККМ Адаптация типовых решений v8 v8::БУ БП3.0 Абонемент ($m)

Простое расширение для загрузки продаж и кассовых операций из систем Frontol. Может использоваться как основа для более полной интеграции

3 стартмани

10.09.2020    1476    0    pbabincev    0    

Конструктор Json Schema с функцией валидации JSON

Обмен данными 1С WEB Интеграция Языки и среды v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Абонемент ($m)

Инструмент для создания Json-схем по формату 4 драфта. В современном мире модно пользоваться Http-сервисами и Json, но если для старого доброго xml все уже придумано и xsd схемы можно рисовать в 1С из коробки, то с json и его форматом Json schema все не так хорошо. Зачастую нужно стандартизировать формат сообщений обмена json и для этого можно воспользоваться Конструктором. Есть возможность проверить свой Json на соответствие схеме. Схемы после выгрузки проходят валидацию в Liquid studio 2020. Стандартизируйте обмен Json с комфортом и удобством.

1 стартмани

16.07.2020    4002    13    Segate    6    

IoT (Internet of Things) в 1С или как подружить 1С с ESP32 при помощи MQTT-брокера

WEB Интеграция Интернет вещей (IIoT) Системная интеграция v8 Абонемент ($m)

Что делать, если надо подключить удалённое устройство к серверу 1С, но ни устройство, ни сервер 1С нельзя "светить" наружу? А если таких устройств десятки или сотни по всей стране? Ответ: Использовать промежуточный сервис, который будет пересылать данные между сервером 1С и устройствами. Такие функции замечательно выполняет MQTT-брокер, но вот не задача, 1С не умеет с ним работать.

1 стартмани

25.06.2020    5144    8    frutty    5    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    58131    47    pbazeliuk    23    

Интеграция АЗС ТОПАЗ и Штрих-М Магазин

Внешние источники данных Интеграция v8 1cv8.cf Россия Абонемент ($m)

Обмен данными между АЗС Топаз 3.14 и 1С на примере Штрих-М: Магазин, редакция 5.1 (5.1.6.8).

1 стартмани

17.06.2020    1905    1    Ignatov_mu    0    

1С:Деньги: Загрузка выписки банка из личного кабинета Тинькофф Банка

Обмен с банком Учет доходов и расходов WEB Интеграция v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Для тех, кто ведет домашние финансы в 1С:Деньги и пользуется услугами Тинькофф Банка. Расширение позволяет загружать операции из личного кабинета Тинькофф Банка напрямую, без промежуточных файлов.

1 стартмани

18.05.2020    3636    16    Bazil    25    

Автоматическая загрузка накладных от поставщиков из электронной почты (Розница 2.2)

Обработка документов Розничная торговля Учет ТМЦ Интеграция Email v8 Розница Россия УУ Абонемент ($m)

Данная обработка предназначена для получения файлов (*.xls;*.xlsx;*.ods;*.dbf) с почтового сервера вашей электронной почты и загрузки прочитанных данных в документы «Поступление товаров». Так же присутствует возможность распаковки архивов, если поставщик шлет вам в письме архивированные файлы (RAR; ZIP; 7Z). Наличие установленного MS Office и Open Office не требуется.

5 стартмани

18.05.2020    3027    6    StiVitS    2    

1C + jabber + python Промо

Сервисные утилиты Практика программирования Интеграция v8 1cv8.cf ДО Абонемент ($m)

Отправка сообщений в jabber из 1С [Документооборота] при помощи python-скрипта.

1 стартмани

14.04.2014    26866    15    Mogidin    2    

Загрузка электронного больничного из файла в ЗУП 3.1. Исправление ошибки

Зарплата Внешние источники данных Интеграция v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

При попытке загрузки электронного больничного пишет: Не заполнено поле LN_HASH или Не заполнено поле LN_STATE. Готовое расширение, исправление для типовой конфигурации ЗУП 3.1.

1 стартмани

08.05.2020    6826    21    Sergeevich    9    

Сканирование магнитных карт (python) и миграция данных в 1С (http - сервис)

Практика программирования Интеграция v8 1cv8.cf Абонемент ($m)

Скрипт чтения com порта (python) и расширение (*.cfe) для приема пакета сообщений в json.

1 стартмани

06.05.2020    2163    0    Legavaz    0    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    5492    8    zavsom    2    

Примеры запросов с календарем Outlook через EWS

Интеграция v8 v8::УФ 1cv8.cf Абонемент ($m)

Примеры создания/изменения/получения/удаления событий календаря Outlook пользователя из 1С через EWS.

2 стартмани

23.04.2020    2587    12    77dream77    0    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    7821    11    zhichkin    16    

Включение и выключение электроприборов из 1С

Интеграция v8 Абонемент ($m)

В публикации я постараюсь описать, как в случае необходимости можно расширить возможности 1С при помощи доступного внешнего оборудования. Рассмотрим, каким образом можно легко включать и выключать электроприборы программно из 1С или имитировать нажатие кнопок.

1 стартмани

02.04.2020    6013    4    bobreks    66    

Все параметры интеграции в одном справочнике

Интеграция v8 Абонемент ($m)

Демо-база для удобного хранения всех параметров интеграции в одном месте и быстрой их замены тестовыми в тестовых базах автоматически. Идея избавляет от ручной смены параметров в тестовых базах; особенно упрощает работу, когда таких параметров значительно много.

3 стартмани

05.03.2020    2192    0    info1i    0    

Выгрузка кодов маркировки обуви в json (для формирования этикетки)

Розничная торговля Интеграция v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Обработка позволяет выгрузить данные о маркируемом товаре в файл json. Проверялась на Управление торговлей, редакция 11 (11.4.11.71) Может понадобиться для реализации печати этикеток для маркировки обуви. Обработку можно подключить как внешнюю обработку в конфигурацию и разместить в определенной подсистеме.

1 стартмани

03.03.2020    3187    4    maksal    2    

Пример связи с API Диадок через сертификат

Интеграция v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Обработка для связи с API Диадок через сертификат формата X.509 - пример подключение при двухфазной аутентификации по сертификату+получение организаций.

1 стартмани

17.02.2020    2441    5    2vadmaster    0    

Интеграция ЗУП с порталом обучения TeachBase

WEB Интеграция v8 ЗУП3.x Россия УУ Абонемент ($m)

Расширение-заготовка для интеграции с TeachBase.

1 стартмани

17.02.2020    2369    2    maksip    0    

Пример http-интеграции ЗУП и HR-портала

Интеграция WEB Расширения v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Расширение для ЗУПа с http-сервисами для интеграции с HR-порталом.

1 стартмани

12.02.2020    3569    3    maksip    5    

Redmine 1C - почти коробка

Управление командой Управление задачами Интеграция v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с системой Redmine.

10 стартмани

10.02.2020    5985    7    zfilin    9    

Интеграция с API Remonline

Обмен данными 1С WEB Интеграция Облачные сервисы, хостинг Расширения v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение для работы с веб-сервисом Remonline.

2 стартмани

05.02.2020    3324    5    Johny_v    3    

Соответствие пользователей Информационной базы и Актив директория

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Эта обработка предназначена для сопоставления пользователей в Информационной базе и пользователей в Актив директории. Пользователи в Информационной базе должны быть прописаны в Актив директории, но иногда получается так, что либо пользователь в Актив директории отсутствует вообще, либо введен в Информационную базу с ошибкой (что равнозначно).

1 стартмани

23.01.2020    2309    5    bryantsev.yury    0    

Интеграция 1С с мессенджером WhatsApp через chat-api

Интеграция v8 1cv8.cf Россия Абонемент ($m)

Это не готовое решение для использования (разве что необходимо будет только массово отправлять сообщения получателям), данная разработка поможет быстрее понять, каким образом необходимо делать интеграцию 1С с мессенджером WhatsApp.

1 стартмани

23.01.2020    3755    28    Hawk_sib    1    

Внешние источники данных: создание таблиц в MS SQL с помощью скриптов *.sql

Внешние источники данных Интеграция v8 Абонемент ($m)

Как быть программисту 1С, если для интеграции базы 1С: Предприятие 8.3 есть техническое задание со стороны разработчика внешней базы данных. Но самой базы данных нет ? А она уже нужна: для отладки выгрузки данных. В тех.задании коллегами описана структура таблиц внешней базы данных. Тогда Вам можно создать такую базу данных самостоятельно. С помощью скрипта для MS SQL.

1 стартмани

21.01.2020    3841    1    Designer1C    5    

Таймер Redmine. Учет времени по задачам

Учет рабочего времени Интеграция Управление задачами v8 v8::УФ 1cv8.cf Абонемент ($m)

Таймер для учета времени в redmine. Быстрый выбор последних задач с активностью, ручной и автоматический ввод данных. Обработка для платформы 8.3, управляемые формы.

2 стартмани

09.01.2020    6343    13    kraynev-navi    3    

Пример взаимодействия 1С и Oracle Primavera

Обмен через XML Интеграция v8 ERP2 Абонемент ($m)

Эта разработка демонстрирует возможность связи 1С:ERP+PM Управление проектной организацией 2 и Oralce Primavera с использованием механизма веб-сервисов со стороны Primavera.

2 стартмани

04.11.2019    5427    9    sunnydragon777    1    

Интеграция с InSales. Обновление цен и остатков товаров

WEB Интеграция Ценообразование, прайсы v8 1cv8.cf Автомобили, автосервисы УУ Абонемент ($m)

Подсистема для интеграции с InSales. Реализация обновления цен и остатков товаров в каталоге на сайте через API. Данный пример реализован на конфигурации Альфа-Авто.

1 стартмани

18.10.2019    6243    12    leobrn    1    

Медовая стыковка с поддержкой входящих налоговых накладных (Украина)

Обмен данными 1С Интеграция v8 v8::УФ 1cv8.cf Украина БУ Абонемент ($m)

Доработка стандартного модуля интеграции 1С с Медком для возможности загрузки входящих налоговых накладных и расчетов корректировки.

1 стартмани

01.10.2019    4253    1    Gorus    0    

Интеграция 1С со сканерами отпечатка пальца ZKTime (обычные формы)

Интеграция v8 1cv8.cf Абонемент ($m)

Интеграция 1С со сканерами отпечатка ZKTime.

1 стартмани

07.08.2019    3475    3    Nefilimus    8    

Универсальная очередь интеграций 1С

Интеграция v8 Абонемент ($m)

"Универсальная очередь" это подсистема, которая позволяет осуществлять достоверную доотправку в случае неуспешно выполненной интеграции, а также выполнять интеграции в фоновом режиме. Очередь может иметь настройки расписания для каждой интеграции отдельно, хранит параметры отправки для каждого элемента очереди. Очередь можно использовать не только для интеграций, но и для выполнения любой процедуры в вашей конфигурации. В приложенном файле конфигурации содержится сама подсистема, а также примеры её использования.

1 стартмани

11.03.2019    6974    8    NovPas    6    

[dotPRICE.ru] Свой интернет-магазин - каждому!

Универсальные обработки WEB Интеграция Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ БГУ Абонемент ($m)

Внешняя обработка позволяет любому пользователю 1С быстро создать собственный интернет-магазин (сервис онлайн-заказов, интернет-каталог продукции...)

1 стартмани

10.01.2016    28514    52    dotPRICE.ru    38    

Выгрузка маршрута в навигационную программу Navitel

Универсальные обработки Интеграция v8 1cv8.cf Абонемент ($m)

Предлагаю вашему вниманию процедуру выгрузки маршрута для навигационной программы Navitel (тестировалось на устройставх android), что может быть полезно например для того чтоб облегчить работу водителей доставки или торговых представителей.

1 стартмани

13.07.2014    23262    28    axilab    3